How do I launch Minecraft with More RAM?

Discussion in 'Rules/Help' started by Punkae, Jan 14, 2014.

  1. Punkae

    Punkae Professional Freelance Tea Addict Staff Member [______________________]

    Okay, this is a simple process with the new launcher. :)

    1. Open your Minecraft Launcher.
    2. Click "New Profile".
    3. Make sure you're running the right version of Minecraft.
    4. Make sure "JVM Arguments" is checked.
    5. Edit the Java Virtual Machine Arguments. You can change it from -Xmx1G to -Xmx2G or similar until you have the right amount of RAM you require.
    6. Launch Minecraft and enjoy.


    :starfull: Tips: :starfull:
    • I would not recommend changing this if your computer only has 1GB of RAM. Also, don't set it to higher than your computer's RAM.
    • If you don't know what your RAM is, click your window's start button (usually at the bottom left) and hover over "computer" and right click "properties". This will show your machine stats.
    • If your computer has 4G, I'd suggest a max of 2G in Minecraft. If you've 6G, 4G, and so on. Change this responsibly, otherwise Minecraft will hog your computer's resources.
    I may make a more in-depth tutorial later.

    Enjoy. :meow<3:

    MC-JVM-Custom-args.PNG

    :member: Member
    Dragonern3 and Sairivon like this.
  2. Sairivon

    Sairivon Moderator Staff Member Moderator

    Always figured that new profile button was to create a new account :x

    Thanks for the info.
  3. Dragonern3

    Dragonern3 Yo, What's up? :P

    I tried to do this but got the message:
    Error: Could not create the java Virtual Machine.
    Error: A fatal exception has occurred. Program will exit.
  4. Punkae

    Punkae Professional Freelance Tea Addict Staff Member [______________________]


    Are you using any client mods? It worked just fine for me, and I currently have nothing external installed.
  5. KiadajTheBeast

    KiadajTheBeast "The Cool Moderator" and Ruler of Kila Staff Member Moderator

    I am using nothing. I got the same message as Dragonern3.
  6. Dragonern3

    Dragonern3 Yo, What's up? :P

    No mods..
  7. DeathsGod

    DeathsGod Trusted

    From what I got from scavenging around on the internet is that either your malware browser protect is messing with it others claim that java 64bit will help since ik for the mod packs launchers such as feed the beast and technic require 64 bit java to allocate more ram, another thing I saw was the user was putting to much ram onto minecraft which cass already said not to
    if need more help heres alittle video made by a 12 year old (I really don't know) but many claim that this video helped solve the issue
    KiadajTheBeast and Punkae like this.
  8. Punkae

    Punkae Professional Freelance Tea Addict Staff Member [______________________]

    DeathsGod , that's incredibly helpful! Thank you!

    I have my settings preadjusted to allow me to use some other things, so that's probably why mine works. ;)

Share This Page